Tutorial Install Proxy OS Ubuntu


Yang Harus disipan
a. Komputer dengan spek:
- Komputer (usahakan AMD) pake intel jg kagak apa2
- RAM 2 GB (asal jangan kurang 1GB)   
- HDD 160 GB (asal jangan kurang dari 80 GB)
 b. Sediain kopi + - 10 Gelas ehehehe

 c. Kopi tanpa Roko Asam X yaaa.. 5 bungkus jg cukup "ceritanya Kirim ke Saya Kalo Kebanyakan"
 d. Langsung aja ke tahap instalasi......
Kamu download dulu CD DISINI kalo belum punya!! (jangan Lupa burning) pake nero aja..
 
LANGKAH-LANGKAHNYA:

1. MASUKKAN CD UBUNTU KE CDROM DAN boot pilih ke cdroom,
2. Pilih language english (enter)
3. Pilih instal ubuntu server (enter)
4. Tekan enter pada choose langguage english
5. Pilih united states
6. Klik no pada detect keyboard layout?
7. Klik USA pada ubuntu installer main menu
8. Klik USA pada keyboard layout
9. Klik continue pada configure the network
10. Pilih configure network manually isi ip address dg 192.168.2.2 pilih continue enter
11. Netmask 255.255.255.0 pilih continue enter
12. Gateway 192.168.2.1 terus klik continue
13. Name server addresses 192.168.2.1 pilih continue enter
14. Hotsnama : isi dg serverku terus pilih continue enter
15. Domain name: di kosongin saja, pilih continue enter
16. Pada configure the clok pilih select from worldwide list terus cari jakarta (sesuaikan lokasi anda) terus enter
17. Pada menu partition disk pilih manual
18. Kita hapus partisi lama dulu :
19. Pilih partisi nya terus enter pilih delete the partion (ulangi perintah ini untuk semua partisi yg tersisa)
20. Jika telah selesai pilih Guided partitioning, kemudian pilih manual arahkan pada FREE SPACE (enter),
21. Pilih Create new partition (enter)
22. New partition size isi 256 mb (pilih continue dan enter), pilih Primary (enter), pilih Beginning (enter), pada use as pilih EXT4 (enter) pada Mount point pilih /boot (enter), pd mount option pilih[*]
noatime (pilih continue dan enter), pada Bootable Flag rubah menjadi on JIKA STATUS NYA TDK BERUBAH ABAIKAN SAJA kemudian pilih done setting up the partition
23. New partition size isi 20 gb (pilih continue dan enter), pilih Primary (enter), pilih Beginning (enter), pada use as pilih EXT4 (enter) pada Mount point pilih / (enter), pd mount option pilih[*] noatime
(pilih continue dan enter), kemudian pilih done setting up the partition
24. Arahkan pada FREE SPACE (enter), pilih Create new partition (enter) new partition size isi 4 gb ( besarnya 2x RAM) pilih continue dan enter, pilih Primary (enter), pilih Beginning (enter), pada use as
pilih swap area (enter), kemudian Pilih done setting up the partition
25. Arahkan pada FREE SPACE (enter), pilih Create new partition (enter) new partition size isi sisa semua harddisk (pilih continue dan enter), pilih Primary (enter), pilih Beginning (enter),
pada use as pilih btrFS atau Reinsfers (enter)
CATATAN :
btrFs untuk 64bit
Reinfers untuk 32bit
pada Moun point enter manually buat menjadi /cache, pd mount option pilih[*] noatime dan realtime kemudian Pilih continue dan done setting up the partition
26. Kemudian pilih finis partitioning and write changes to disk, write the changes to disk pilih yes
27. pada full name for the new user isi dg serverku, terus continue & enter
28. pada Username for your account isi dg serverku, terus continue & enter
29. pada a password for the new user isi dg serverku, terus continue & enter
30. pada re-enter password to verify isi dg serverku, terus continue & enter
31. pada use weak password pilih yes
32. pada encrypt your home directory pilih no
33. pada HTTP Proxy information KOSONGIN SAJA
34. pada configurasi apt 43% tekan enter, juga pada 81% tekan enter pilih no automatic update
35.pada choose software to install pilih OpenSSH server pilih continus pd finish the installation dan reboot, ambil CD Ubuntu, 1st Boot kembalikan ke Hardisk
selanjutnya
# login dg serverku
# password serverku
# ketik sudo su -
# isi serverku
jika menginginkan login sebagai root setiap reboot ubuntu ikuti langkah berikut :
# ketik passwd
# enter new UNIX password isi dg serverku
# retype new UNIX password isi serverku
# reboot
Install Proxy Lusca FMI via Putty
Setelah selesai instalasi ubuntunya mari kita lanjutkan ke Cara Install Proxy Lusca FMI di Ubuntu 10.10 64Bit
1. Hubungkan PC Proxy dengan Mikrotik memakai kabel RJ45 mode Cross
2. Remote Ubuntu server kita Dengan PuTTY dari PC admin
Jika belum punya silahkan downloada di sini Aplikasi Untuk Mikrotik & Proxy
3. Login ke root cek Ping ke public utuk internetnya jika sudah jalan mari kita lanjutkan,..
4. Update & upgrade repositor Ubuntu
Copas kode dibawah ini dan pastekan di terminal PuTTY ( klik kanan lalu Enter )
apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y && apt-get install squid -y && apt-get install squid squidclient squid-cgi -y && apt-get install gcc -y && apt-get install build-essential -y && apt-get install sharutils -y && apt-get install ccze -y && apt-get install libzip-dev -y && apt-get install automake1.9 -y && wget http://proxy-ku.googlecode.com/files/LUSCA_FMI.tar.gz && tar xzvf LUSCA_FMI.tar.gz && cd LUSCA_FMI/ && make distclean
Tunggu sampai selesai, lama waktu update tergantung koneksi internet kita!!
5. Lakukan perintah compile Untuk Lusca FMI
Copas Kodennya:
./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-http-gzip --enable-async-io=24 --with-aufs-threads=24 --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=heap --with-aio --with-dl --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --disable-unlinkd --enable-large-cache-files --with-large-files --enable-err-languages=English --enable-default-err-language=English --with-maxfd=65536 && make && make install
6. Setelah proses selesai lanjutkan pada proses berikut
Copy file-file berikut dengan Program WinSCP
============================================
- File "squid.conf" yang telah disesuaikan ke folder: /etc/squid/
- File "storeurl.pl" ke folder: /etc/squid/
- File "squid" ke folder: /etc/init.d/
Jika belum punya squid.conf dll nya silahkan download disini Perlengkapan Squid Proxy Lusca FMI. (edit dan sesuaikan )
Setelah seleseai di copy mari kita lanjutkan langkah berikutnya :
============================================
7. Memberikan izin akses kepada user squid
Copas Kodennya:
chmod +x /etc/init.d/squid && /etc/init.d/squid stop
8. Memberikan permission pada folder cache
Copas Kodennya:
chown proxy:proxy /cache && chmod 777 /cache chown proxy:proxy /etc/squid/storeurl.pl && chmod 777 /etc/squid/storeurl.pl && chmod +x /etc/init.d/squid
9. Membuat folder swap/cache di dalam folder cache
============================================
/etc/init.d/squid stop
squid -f /etc/squid/squid.conf -z && /etc/init.d/squid restart

10. Agar proses shutdown dapat langsung dijalankan dengan menekan tombol Power gunakan perintah berikut:
Copas Kodennya:
apt-get install acpid
------- reboot -------

buka di winbox kemudian pastekan di terminal mikrotik script di bawah :

/ip firewall address-list add address=192.168.2.0/24 comment="SQUID PROXY EXTERNAL" disabled=no list="ProxyNet"

/ip firewall nat add action=dst-nat \
chain=dstnat comment="TRANSPARENT DNS UDP LOCAL" \
disabled=no dst-port=53 in-interface=local \
protocol=udp to-ports=53

/ip firewall nat add action=dst-nat \
chain=dstnat disabled=no dst-port=53 in-interface=proxy \
protocol=udp to-ports=53 comment="TRANSPARENT DNS UDP PROXY"

/ip firewall nat
add chain=dstnat action=dst-nat to-addresses=192.168.2.2 to-ports=3128 \
protocol=tcp src-address=192.168.11.0/24 src-address-list=!ProxyNet \
comment="REDIRECT KE PROXY" in-interface=Local dst-port=80,3128,8080

C a t a t a n :
Silahkan edit dan sesuaikan dengan jaringan sobat!
sumber : http://warnet-jaya.blogspot.com/2012/12/tutorial-install-proxy-os-ubuntu.html
Share :

Komentar Facebook:

iklan banner iklan banner iklan banner iklan banner

Artikel Terbaru

Recent Posts
Histats.com